Forums Home
 
Forums  ›  Sound setups  ›  Sound Setup
 

Guitar Rig and VAC Virtual Audio Cables

Guitar Rig and VAC Virtual Audio Cables on OJS.

11-26-10 I finally got my set up to play here. I do not use any amp at all. Only my PC(Windoze 7), Guitar Rig 4 and Virtual Audio Cable(aka VAC)...my browser too...of course. This should also work for Amplitube etc...I will test that soon, and my sequencers....... Here is how I do it. First... In Start Menu Right click on Computer. Click Manage. Double click Services and Applications. Click Services. Scroll down to Windows Audio Services. STOP service. Will START service back again "later". {NOTE: The reason for this is only if MS GS Wavetable is interfering with ASIO4all. It probably will. It did it to me.} Second... Make sure your sound card(mine is onboard Realtek HD audio) is set as default sound AND that Exclusive mode is OFF(unchecked). To do that...Right click on the little speaker icon at the bottom right of your screen. Click Playback devices. Select your output(sound card). {NOTE: An Audio Interface "probably" does NOT need all of this. It should have more capabilities than an ordinary sound card.} ok...back to it. Set your sound card as default.(You should see Set Default. click it.) Once that is set...right click on said device. Click Properties. Go to the Advanced tab. Uncheck everything under Exclusive mode. Click OK. Third... In Guitar Rig...set your line in to where you have your guitar plugged in. I use an adapter...1/4 to 1/8th into line in rear panel(blue). You have to set this in your ASIO4all control thingy in Guitar Rig. Do I need to explain that? If so...I will re-edit this post and include it later. k? OK...then set your line out to VAC 1. Fourth... Start VAC control panel. You need at least ONE(so-far) virtual cable. Strat Audio Repeater(comes with VAC.) In audio repeater set wave in as VAC 1. Set wave out as your sound card. START the audio repeater...you'll see the button. Fifth... Start your browser. Log on to OJS jam room. Right click anywhere inside the "room". Click Settings. Click the little Microphone...select Line In VAC 1. {NOTE: The browser automatically defaults its output to your default card. That was one of the problems in doing this. IF Flash had output in settings...some really cool stuff could be done. Anybody know how to program a Flash plugin?} OK lastly...go back to services...START Windows Audio services. Ummm...I could have told ya wrong. This may have needed to have been done after starting GR4. Well give it a shot. I will retest mine too. I will hopefully be adding other stuff about audio set up...etc... Please tell me what you think. Thank you all. David